我要投稿 如果你有好的文章,欢迎分享给我们,我们会给与适当的补贴

树莓派 3B+ 与OpenWRT

最近一直在尝试如何在树莓派3B+上面安装OPENWRT,目前看来,只有snapshots的版本支持,安装之后不会有彩虹屏。另外一个问题就是安装之后没有luci的界面,需要用户自己安装。这个也需要一定的动手能力。

下面是snapshots的版本的下载地址
下载: https://downloads.openwrt.org/snapshots/targets/brcm2708/bcm2710/
Broadcom firmware files (brcmfmac43455-sdio.*) from Raspbian to /lib/firmware/brmc/ then reboot.

/etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdd2:ea72:580f::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option proto 'static'
option gateway '192.168.2.1'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.2.11'
option dns '8.8.4.4'

Add a Comment

电子邮件地址不会被公开。 必填项已用*标注